Power has been restored on campus and network access is available in almost all locations. IT is working to resolve network issues impacting a limited area in Nazareth Hall.
Posted Jun 10, 2026 - 11:13 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 10, 2026 - 06:32 CDT
Investigating
Information Technology is aware of internet access being down in the following buildings due to a power outage.
IT is monitoring the situation and will verify internet access once campus power is restored. Updates will be posted to the IT status page.
Posted Jun 10, 2026 - 04:11 CDT
This incident affected: Campus Building Networks (Berntsen Library Network, Billy Graham Community Life Commons Network, Ericksen Center Network, Hartill/Knutson/Roberston Student Center Network, Mel Johnson Media Center Network, Moyer Hall Network, Nazareth Hall Network, Powerhouse Network, Ramseyer Hall Network, Riley Hall Network, Totino Fine Arts Center Network) and Campus Network and Systems (Wireless).