Microsoft Azure Outage Alert

Incident Report for UNW IT Systems

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 12:59 CDT

Monitoring

Dynamic Forms has been restored but we are continuing to monitor the situation.
Posted Oct 29, 2025 - 14:04 CDT

Investigating

Information Technology is aware of a Microsoft Azure outage affecting the services listed below provided by a third-party vendor.

Updates will be posted to the IT status page as they are made available.
Posted Oct 29, 2025 - 12:27 CDT
This incident affected: Applications and Services (Dynamic Forms).