Wi-Fi Registration Issue Alert

Incident Report for UNW IT Systems

Identified

The issue has been identified and our vendor is working on a fix.
Posted Aug 26, 2026 - 16:12 CDT

Investigating

Information Technology is aware of an issue with Wi-Fi registration where some users are unable to register due to a "physical address not found" error.

If you are seeing this error message, please contact the Service Desk by stopping by Riley Hall Room 0122, or calling 651-631-5699.

IT is actively working to resolve the issue.  Updates will be posted to the IT status page.
Posted Aug 26, 2026 - 10:46 CDT
This incident affects: Campus Network and Systems (Wireless).