Dynamic Forms Outage Alert

Incident Report for UNW IT Systems

Resolved

This incident has been resolved.
Posted Aug 19, 2026 - 08:50 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2026 - 12:14 CDT

Investigating

Information Technology is aware of an issue affecting Dynamic Forms. Some pages may load slowly or time out. Our vendor is aware of the issue and is working to restore normal performance.

Updates will be posted to the IT status page within the hour.
Posted Aug 18, 2026 - 11:34 CDT
This incident affected: Applications and Services (Dynamic Forms).