Web Donation Forms Outage Alert

Incident Report for UNW IT Systems

Resolved

This issue was resolved at 9:30am.
Posted Sep 10, 2026 - 13:02 CDT

Investigating

Information Technology is aware of an issue affecting the services listed below provided by a third-party vendor.

- Donation forms and online forms on our websites through the give.unwsp.edu URL are unavailable.

IT is engaging the vendor to resolve the issues. Updates will be posted to the IT status page as they are made available.
Posted Sep 10, 2026 - 09:16 CDT
This incident affected: Applications and Services (Fundraising Applications).