IT Outage Alert - Evisions Applications

Incident Report for UNW IT Systems

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 14:34 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 11, 2025 - 14:19 CDT

Investigating

Information Technology is currently investigating reports of a potential service interruption to Evisions Applications (Argos, Form Fusion, and Intellicheck). 

Updates will be posted to the IT status page as staff work to identify and resolve the issue.
Posted Jul 11, 2025 - 13:57 CDT
This incident affected: Applications and Services (Evisions Applications).