We have a fix for the Microsoft Excel copy and paste issue and will begin deploying it to affected Windows computers tonight, Friday, September 11, starting at 10 p.m.
What to Expect
- If you are leaving your computer on overnight, please save your work and close Word, Excel, Outlook, and other Office applications before you leave. - If you are working while the fix runs, you will see a notification on your computer and will be prompted to close any open Office applications. - The fix may take several minutes to complete. No files or data are affected. - Computers that are powered off tonight will receive the fix the next time they are on and connected.
If Excel copy and paste is still not working afterward, contact the Service Desk at http://it.unw.edu or 651-631-5699.
Note: Media stations which have fundraisers scheduled next week have been excluded from this change.
Posted Sep 11, 2026 - 17:16 CDT
Identified
Information Technology is aware of an issue affecting Microsoft Excel.
A recent Microsoft security update has broken a number of features in Excel 2021 on Windows computers. Microsoft 365 Office Excel is not affected. On Excel 2021, the following features may not work: Ctrl+C and Ctrl+V, dragging a formula, and pressing Esc may not clear a copied selection.
In the meantime, Excel for the web using OneDrive or SharePoint is not affected, or you can upgrade to the Microsoft 365 Office Excel via the Northwestern Self Service app. On some computers, using right-click Copy and Paste from the menu instead of the keyboard shortcuts also works.
IT is actively working to resolve the issue. Updates will be posted to the IT status page.
Posted Sep 11, 2026 - 13:54 CDT
This incident affects: Applications and Services (Office 365 Apps).