Canvas Outage Alert

Incident Report for UNW IT Systems

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 31, 2026 - 15:46 CDT

Investigating

Information Technology is aware of an issue where Canvas is not loading for some users.

IT is engaging the vendor to resolve the issues. Updates will be posted to the IT status page as they are made available.
Posted Aug 31, 2026 - 12:54 CDT
This incident affects: Applications and Services (Canvas).