The issue has been resolved. Blackbaud has renewed the security certificate associated with give.unwsp.edu, and all donation forms and website forms are now operational.
Posted Aug 17, 2026 - 21:08 CDT
Investigating
Information Technology is aware of an issue affecting the systems listed below.
The SSL certificate for give.unwsp.edu has expired. As a result, all donation forms are currently displaying a "certificate has expired" error. In addition, web forms embedded across all station websites are not loading and are unavailable to users at this time.
We are actively working with Blackbaud to restore service as quickly as possible.
Updates will be posted to the IT Status Page as soon as additional information becomes available from Blackbaud.
We apologize for the inconvenience and appreciate your patience.
Posted Aug 17, 2026 - 20:45 CDT
This incident affected: Applications and Services (Fundraising Applications).